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Abstract: The design and implementation of an IOT-controlled metal detecting robot for efficient and 

accurate detection of metallic objects in various environments. The robot integrates IOT technology, 

including sensors and wireless communication, to enable remote control and real-time monitoring. The 

system utilizes a combination of metal detectors and proximity sensors to identify and navigate around 

obstacles while detecting metal objects. Through the integration of IOT, the robot can be controlled and 

monitored remotely via a Smartphone or web interface, providing flexibility and convenience to users. 

Experimental results demonstrate the effectiveness and reliability of the proposed system in detecting and 

navigating through diverse environments, showcasing its potential applications in security, industrial, and 

archaeological fields. 
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I. INTRODUCTION 

Robots can be utilized to complete work in perilous zones and can be used to manage troublesome instability levels in 

such areas. Gradually robots are becoming dynamically vital for standard subject applications, for instance. A variety of 

small robotic applications are now arising where robots are utilized to complete an assortment of errands. By and large, 

robots are still utilized for unsafe work which is dangerous for humans. Metal detecting robot is utilized to search for 

metal objects covered up in the ground. Electricians also use metal detectors to scan for electrical cables hidden in 

walls. At airplane terminals, metal finders are utilized to scan travelers for metal protests, for example, cuts and 

firearms. For searching old combat zones and historical sites, hoping to find treasures, jewelry and old coins, metal 

detectors are frequently used. In food factories, they are used to check and verify that no metal things have fallen from 

industrial factories into the food unintentionally. 

Different technological terms such as Telecommunication, Internet of Things (IOT), and robotics have been considered 

a vital part of our daily activities. Although its advances and limitations, innovative tech can be solved fundamental 

issues and save lives for many people for political or financial purposes. In the electronic era, speed, flexibility, and 

automation are major defiance that is enabling researchers to meet the challenges of the society against the quick 

development of the techs. Robotics has been becoming dynamically significant for several standard applications. 

Applications such as military, Salvage and Urban Hunt. Due to its human reduction activities in a severe environment. 

Effectiveness metal and landmine detections are two vital research areas that still considered more attractive to 

researches due to investing tech. According to Landmine and cluster monition monitor. Multi sensor robot, path 

planning algorithm and vehicle-mounted sensors are different strategies that used to search and detect mines. 

  

II. LITERATURE SURVEY 

While many techniques have been developed for military use, the military problems is quite distinct from that of 

humanitarian demining. The military is concerned mainly with minefield breaching. Rapidly clearing a route thought a 

minefield, leaving most of the mines in place. To achieve these ends, military systems tend to rely on high — troubled 

operation. This is clearly insufficient for humanitarian use as even the fear of the presence of landmines will result in 

land remaining uninhibited. Minefield surveys are typically classified into three levels. Level 1st surveys are designed 

to identify the general location of mined or suspected mines areas. A Level II surveys is designed to reduce the large 

areas identify in level 1st surveys. A level III survey are conducted during the actual clearance of the areas identified in 
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the level II to surveys and involves the accurate recording of the areas cleared. Now, this project allows us to taking a 

brief literature survey from the various journals, scholars, papers, thesis on automated metal detection robot. i.e. 

1. According to paper added to IEEE explore on 6 March 2017, Demining or mine clearing is the process of detecting 

and removing land mine from an area. Un cleared landmines represent a serious humanitarian and economic threat in 

over 70 countries. Its victims suffer from permanent disability if not killed and need horrific expensive care. Also 

Clearing mines is very dangerous work. The majority of demining work remains administered manually using metal 

detectors and prodders. For every 5,000 mines that are removed, one person is killed and two people are injured. Over 

the years there has been considerable interest within the scientific and engineering communities within the application 

of advanced technologies to enhance the security and efficiency of this work. In this paper a motion-planning algorithm 

to enable landmine detection and clearing robots to systematically scan a minefield, detect landmines and clear it's 

presented. The algorithm works on two steps; (1) generate the driving tracks which will be wont to scan the minefield 

area, and (2) connect these tracks using Dubins' path in order to get a continues and complete trajectory which may be 

used for the robot's navigation. 

  

III. PROBLEM STATEMENT 

The implementation of IOT-based metal detectors presents a significant challenge in the context of enhancing security, 

safety, and efficiency in various domains, including transportation, infrastructure, and public spaces. Traditional metal 

detectors have long been the go-to technology for identifying concealed metallic objects. However, they often fall short 

in terms of real-time data collection, remote monitoring, and integration into broader security systems. To address this 

issue and leverage the potential of IoT technology, the development of IoT-based metal detectors is essential. 

Nonetheless, several critical problems need to be addressed: 

1. Detection Accuracy and False Alarms: Ensuring the accuracy of metal detection while minimizing false 

alarms is a complex problem. Variability in metallic object composition, size, and orientation can 

challenge the precision of detection systems. Balancing sensitivity with specificity is essential to avoid 

inconveniencing individuals and ensure reliable threat detection. 

2. Data Integration and Real-time Monitoring: Integrating IOT-based metal detectors into existing security 

systems or creating new monitoring platforms for real- time data analysis and alerts are crucial. This 

requires addressing interoperability challenges, data transmission, and effective visualization to enable 

swift responses to detected threats. 

3. Power Efficiency: IOT-based metal detectors are often expected to operate continuously in various 

environments, including remote and off-grid locations. Balancing power efficiency with operational 

requirements is essential to ensure extended device uptime and minimal maintenance. 

4. Environmental Resilience: Metal detectors are often used outdoors and exposed to a range of 

environmental conditions, including extreme temperatures, humidity, and physical stress. Designing these 

devices to withstand these conditions while maintaining operational effectiveness is a complex issue. 

5. Cost-effectiveness: Balancing the cost of implementing IoT-based metal detectors with their functionality 

and performance is vital. Achieving affordability without compromising detection capabilities is a key 

challenge, especially for applications with budget constraints. 

The successful implementation of IOT-based metal detectors requires addressing these multifaceted challenges to 

deliver reliable, efficient, and secure threat detection solutions in diverse environments and applications. This project 

aims to develop innovative solutions that can overcome these problems and lead to a more accessible, adaptable, and 

effective security ecosystem, contributing to the safety and security of various public spaces and critical infrastructure. 
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IV. METHODOLOGY BLOCK DIAGRAM  

 
 

HARDWARE REQUIREMENT: 

 ESP-32 Microcontroller (In built WIFI) 

 16X2 LCD display 

 Ds18b20temperature sensor 

 HC-SR04(Obstacle sensor - ultrasonic sensor) 

 Metal Detection sensor 

 L293D motor Driver IC 

 DC-12v Gear Motor – 60 RPM 

 ESP32- Camera Module 

 Battery 12v 4.5 Ah 
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ESP-32 MUC: 

 

Specifications – ESP32 DEVKIT V1 DOIT 

The following table shows a summary of the ESP32 DEVKIT V1 DOIT board features and specifications: 

Number of cores 2 (dual core) 

Wi-Fi 2.4 GHz up to 150 Mbits/s 

Bluetooth BLE (Bluetooth Low Energy) and legacy Bluetooth 

Architecture 32 bits 

Clock frequency Up to 240 MHz 

RAM 512 KB 

Pins 30, 36, or 38 (depending on the model) 

 

 

Peripherals 

Capacitive touch, ADC (analog to digital converter), DAC (digital to analog converter), I2C (Inter-

Integrated Circuit), UART (universal asynchronous receiver/transmitter), CAN 2.0 (Controller Area

Network), SPI (Serial Peripheral Interface), I2S (Integrated Inter-IC Sound), RMII (Reduced Media-

Independent Interface), PWM (pulse width modulation), and more. 

Built-in buttons RESET and BOOT buttons 

Built-in LEDs built-in blue LED connected to GPIO2; built-in red LED that shows the board is being powered 

USB to UART 

bridge 

CP2102 
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16X2 LCD display: 

 

LCD (Liquid Crystal Display) screen is an electronic display module and find a wide range of applications. A 16x2 

LCD display is very basic module and is very commonly used in various devices and circuits. These modules are 

preferred over even segments and other multi segment LEDs. The reasons being: LCDs are Economical; easily 

programmable; have no limitation of   displaying   special   &   even custom   characters (unlike   in   seven segments), 

animations and so on. 

 

Ds18b20 TEMPERATURE SENSOR: 

 

This is a 1 Meter Long Waterproof, sealed and pre-wired digital temperature sensor probe based on DS18B20 sensor. It 

is very handy for when you need to measure something far away, or in wet conditions. Because they are digital, you don't 

get any signal degradation even over long distance. These 1-wire digital temperature sensors are fairly precise (±0.5°C 

over much of the range) and can give up to 12 bits of precision from the onboard digital-to-analog converter. They 

work great with any microcontroller using a single digital pin, and you can even connect multiple ones to the same pin, 

each one has a unique 64-bit ID burned in at the factory to differentiate them. Usable with 3.0-5.0V systems. The only 

downside is they use the Dallas 1-Wire protocol, which is somewhat complex, and requires a bunch of code to parse out 

the communication. When using with microcontroller put a 4.7k resistor to sensing pin, which is required as a pullup 

from the DATA to VCC line. 
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Ds18b20 SENSOR TECHNICAL SPECIFICATIONS: - 

Usable temperature range: -55 to 125°C (-67°F to +257°F) 

9 to 12 bit selectable resolution 

Uses 1-Wire interface- requires only one digital pin for communication 

Unique 64 bit ID burned into chip 

Multiple sensors can share one pin 

±0.5°C Accuracy from -10°C to +85°C 

Temperature-limit alarm system 

Query time is less than 750ms 

Usable with 3.0V to 5.5V power/data 

 

HCSR04(ULTRASONIC SENSOR): 

 

This ultrasonic sensor module can be used for measuring distance, object sensor, motion sensors etc. High sensitive 

module can be used with microcontroller to integrate with motion circuits to make robotic projects and other distance, 

position & motion sensitive products. 

The module sends eight 40Khz square wave pulses and automatically detects whether it receives the returning signal. If 

there is a signal returning, a high level pulse is sent on the echo pin. The length of this pulse is the time it took the signal 

from first triggering to the return echo. 

 

FEATURES: 

 Sensor Type: Ultrasonic 

 Output: Digital Sensor 

 Voltage: 5VDC 

 Detection distance: 2cm-400cm (0.02M - 4.0M) 

 Static current: < 2mA 

 Level output: high-5V 

 High precision: up to 0.3cm 
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METAL DETECTION SENSOR: 

 

we can use this Metal detector non-contact metal induction detection module as a metal detector. When it approaches 

any metal, it makes a sound. 

This is a module specifically designed to detect metal. The module operates by inducing currents in metal objects and 

responding when it occurs. A nice onboard buzzer signals when it detects something and an onboard potentiometer 

allow adjustment of sensitivity. 

The power cables of the Metal detector non-contact metal induction detection module will need soldering on for the 

module to function, positive to the outside of the module and negative between the potentiometer and an electrolytic 

capacitor. 

 

FEATURES: 

V+ Connect to power positive 

V- connect to power negative 

Adjust the potentiometer, let the modules work normally. 

Small and easy to use module. 

It comes with a Buzzer for metal detection indication 
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L293D MOTOR DRIVER IC: - 

 

The L293D is most often used to drive motors, but can also be used to drive any inductive load such as a relay solenoid or 

large switching power transistor. It is capable of driving four solenoids, four uni-directional DC motors, two bi-

directional DC motors or one stepper motor. The L293D IC has a supply range of 4.5V to 36V and is capable of 1.2A 

peak output current per channel, so it works very well with most of our motors. 

IN1 IN2 Spinning Direction 

Low (0) Low (0) Motor OFF 

High (1) Low (0) Forward 

Low (0) High (1) Backward 

High (1) High (1) Motor OFF 

 

DC-12V GEAR MOTOR – 60 RPM: 
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DC Motor – 60RPM – 12Volts geared motors are generally a simple DC motor with a gearbox attached to it. This can be 

used in all-terrain robots and variety of robotic applications. These motors have a 3 mm threaded drill hole in the 

middle of the shaft thus making it simple to connect it to the wheels or any other mechanical assembly. 60 RPM 12V 

DC geared motors widely used for robotics applications. 

The most popular L298N H-bridge module with onboard voltage regulator motor driver can be used with this motor that 

has a voltage of between 5 and 35V DC or we can choose the most precise motor diver module from the wide range 

available in our Motor divers category as per your specific requirements. 

Nut and threads on the shaft to easily connect and internally threaded shaft for easily connecting it to the wheel. DC Geared 

motors with robust metal gearbox for heavy-duty applications, available in the wide RPM range and ideally suited for 

robotics and industrial applications. Very easy to use and available in standard size. Nut and threads on the shaft to 

easily connect and internally threaded shaft for easily connecting it to the wheel. 

 

SPECIFICATIONS AND FEATURES: - 

RPM: 60. 

Operating Voltage: 12V DC 

Gearbox: Attached Plastic (spur)Gearbox 

Shaft diameter: 6mm with internal hole 

Torque: 2 kg-cm 

No-load current = 60 mA (Max) 

Load current = 300 mA (Max). 

 

ESP32- CAMERA MODULE: 
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The ESP32-CAM is an Ai-Thinkers Original ESP32 CAM WiFi+Bluetooth with OV2640 Camera Module based on the 

ESP32 chip with the additional facility of using a camera. It is ideal for various IOT applications. The ESP32-CAM has 

a very competitive small-sized camera module that can operate independently as a minimum system. Ai-Thinker ESP32 

CAM can be widely used in various IOT applications. It is suitable for home smart devices, industrial wireless control, 

wireless monitoring, QR wireless identification, wireless positioning system signals and other IOT applications. It is an 

ideal solution for IOT applications. 

ESP32-CAM is packaged in DIP and can be directly plugged into the backplane for quick production. It provides 

customers with a highly reliable connection method and is convenient for use in various IOT hardware terminals. 

 

FEATURES: 

Ultra-small 802.11b/g/n Wi-Fi + BT/BLE SoC module 

Low-power dual-core 32-bit CPU for application processors 

Up to 240MHz, up to 600 DMIPS 

Built-in 520 KB SRAM, external 4M PSRAM 

Supports interfaces such as UART/SPI/I2C/PWM/ADC/DAC 

Support OV2640 and OV7670 cameras with built-in flash 

Support for images Wi-Fi upload 

Support TF card 

Support multiple sleep modes 

Embedded Lwip and FreeRTOS 

Support STA/AP/STA+AP working mode 

Support Smart Config/AirKiss One-click distribution network 

Support for serial local upgrade and remote firmware upgrade (FOTA) 

 

BATTERY 12V 7.2 AH: 

 

SPECIFICATIONS AND FEATURES: - 

Maintenance free lead acid battery with Strong ABS Body. Recharge after every use. 

Voltage: 12V - 1.3AH (1300mah); Initial Current: Less than 0.39A 

Cycle Use: 14.4V - 15V; Standby Use: 13.5V 13.8V 

Battery Size: 97 x 45 x 53 mm (L x W x H) 
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SOFTWARE REQUIREMENT: 

Arduino IDE 

USB cable for Programming. 

IOT app for operation  

 

WORKING 

This Project presents a new type of robot that uses a metal detector sensor to detect metallic object passing over the 

metal detector. The robotic vehicle is controlled using android application for metal detection operation controlled with 

the help of WIFI technology. This project can be widely used because of its simplicity and ability to modify to meet 

changes of needs. Based on experimental studies, it was found that the mobile controlled robot can move in any 

direction as per the desired instruction and the beeper in the metal detector circuit beeps whenever it encounters any 

metallic object. The embedded hardware has been developed on ESP32 microcontroller and controlled by an Android 

smart phone. This controller receives the commands from the Android phone, takes the data and controls the motors of 

the robot by the motor driver L293D. The robot can able to move forward, backward, left and right movements. The 

Smartphone is been interfaced to the device by using WIFI. A WIFI device EP32camera module was used with ESP32 

MUC to receive commands from the Smartphone. A metal detector circuit was connected to the robot to detect the 

metal. A beep sound was made when it detected the metal. A Temperature sensor is connected to MUC to alert if any 

fire and avoid that path from moving further. An EPS32 camera is connected to live streaming of video which can be 

watched online in mobile or web page. An ultrasonic sensor is connected to MUC as an obstacle sensor if any obstacle 

finds while moving it stop from further motion to avoid damage to robot. All information is passed to IOT web server 

which can be easily viewed and controlled 

 

V. CIRCUIT DIAGRAM AND EXPLANATION 

EXPLANATION: 

The robotic vehicle consists ESP32 microcontroller attached with four wheels for the movement of the vehicle over the 

land. When a Landmine is detected, the robotic vehicle stops at that position and activates the buzzer and sends the live 

feeding image to server. The ESP32 Wi-Fi Module is a self-contained SOC with integrated TCP/IP protocol stack that 

can give any microcontroller access to your Wi-Fi network. The ESP32 is capable of either hosting an application or 

offloading all Wi-Fi networking functions from other application. Which gets live image through web camera and any 

obstacle through ultrasonic sensor position through online access and give it to the controller. Through wife module he 

positioning data from the controller is send to internet of things which stores the data in cloud. On surfing through the 

internet, the exact position of the landmine can be accessed and the corresponding landmine can be removed. Four 

motor is controlled using LM293D driver IC and LCD 16x2 display is used for displaying information received from 

iot server. Everything is controlled remotely through IOT using Arduino cloud IOT platform. Program is developed with 

embedded C using Arduino IDE 2.0 version 
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VI. SOFTWARE USED 

SOFTWARE INSTALLATION 

In these we will get know of the process of installation of Arduino IDE and connecting Arduino Uno to Arduino IDE. 

STEP 1 

First, we must have our Arduino board (we can choose our favorite board) and a USB cable. In case we use Arduino 

UNO, Arduino Duemilanove, Nano, Arduino Mega 2560, or Diecimila, we will need a standard USB cable (A plug to 

B plug), In case we use Arduino Nano, we will need an A to Mini-B cable. 
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STEP 2 -Download Arduino IDE Software. 

We can get different versions of Arduino IDE from the Download page on the Arduino Official website. We must 

select wer software, which is compatible with wer operating system (Windows, IOS, or Linux). After wer file download 

is complete, unzip the file. 

 

STEP 3 -Power up our board. 

The Arduino Uno, Mega, Duemilanove and Arduino Nano automatically draw power from either, the USB connection 

to the computer or an external power supply. If we are using an Arduino Diecimila, we have to make sure that the board 

is configured to draw power from the USB connection. The power source is selected with a jumper, a small piece of 

plastic that fits onto two of the three pins between the USB and power jacks. 

Check that it is on the two pins closest to the USB port.Connect the Arduino board to wer computer using the USB 

cable. The green power LED (labeled PWR) should glow 

 

STEP 4 − Launch Arduino IDE. 

 

After our Arduino IDE software is downloaded, we need to unzip the folder. Inside the folder, we can find the application 

icon with an infinity label (application.exe). Double- click the icon to start the IDE. 

 

STEP 5 − Open our first project. 

Once the software starts, we have two options 

* Create a new project 
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. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Open an existing project example. 

To create a new project, select File → New. 

To open an existing project example, select File → Example → Basics → Blink. 

Here, we are selecting just one of the examples with the name Blink. It turns the LED on and off with some time delay. 

We can select any other example from the list. 

 

STEP 6 − Select our Arduino board. 
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To avoid any error while uploading wer program to the board, we must select the correct Arduino board name, which 

matches with the board connected to wer computer. 

Go to Tools → Board and select wer board. 

Here, we have selected Arduino Uno board according to our tutorial, but we must select the name matching the board 

that we are using 

 

STEP 7 − Select wer serial port. 

 

Select the serial device of the Arduino board. Go to Tools → Serial Port menu. This is likely to be COM3 or higher 

(COM1 and COM2 are usually reserved for hardware serial ports). To find out, we can disconnect wer Arduino board and 

re-open the menu, the entry that disappears should be of the Arduino board. Reconnect the board and select that serial 

port. 

 

STEP 8 − Upload the program to wer board. 

Before explaining how we can upload our program to the board, we must demonstrate the function of each symbol 

appearing in the Arduino IDE toolbar. 
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A − Used to check if there is any compilation error. B −Used to upload a program to the Arduino board. 

C − Shortcut used to create a new sketch. 

D−Used to directly open one of the example sketches. E − Used to save wer sketch. 

F − Serial monitor used to receive serial data from the board and send the serial data to the board. 

Now, simply click the "Upload" button in the environment. Wait a few seconds; we will see the RX and TX LEDs on the 

board, flashing. If the upload is successful, the message "Done uploading" will appear in the status bar. 

Note − If we have an Arduino Mini, NG, or other board, we need to press the reset button physically on the board, 

immediately before clicking the upload button on the Arduino Software 

 

ARDUINO SOFTWARE (IDE) COMPILER 

The Arduino Integrated Development Environment - or Arduino Software (IDE) - contains a text editor for writing 

code, a message area, a text console, a toolbar with buttons for common functions and a series of menus. It connects to 

the Arduino and Genuino hardware to upload programs and communicate with them 

 

WRITING SKETCHES 

Programs written using Arduino Software (IDE) are called sketches. These sketches are written in the text editor and are 

saved with the file extension. ino. The editor has features for cutting/pasting and for searching/replacing text. The 

message area gives feedback while saving and exporting and also displays errors. 

The console displays text output by the Arduino Software (IDE), including complete error messages and other 

information. The bottom righthand corner of the window displays the 

Configured board and serial port. The toolbar buttons allow you to verify and upload programs, create, open, and save 

sketches, and open the serial monitor. 

NB: Versions of the Arduino Software (IDE) prior to 1.0 saved sketches with the extension. pde. It is possible to open 

these files with version 1.0, you will be prompted to save the sketch with the. ino extension on save. 

 

 
Verify 

Checks your code for errors compiling it. 

 

 

Upload 

Compiles your code and uploads it to the configured board. See uploading below for details. 

Note: If you are using an external programmer with your board, you can hold down the "shift" key on your 

computer when using this icon. The text will change to "Upload using Programmer" 

 

 

 

 

New 

Creates a new sketch. 

 

 

 

Open 

Presents a menu of all the sketches in your sketchbook. Clicking one will open it within the current

window overwriting its content. 

Note: due to a bug in Java, this menu doesn't scroll; if you need to open a sketch late in the list, use the File 

| Sketchbook menu instead. 

 

 

Save 

Saves your sketch. 

 

 

Serial Monitor 

Opens the serial monitor. 

 



IJARSCT  ISSN (Online) 2581-9429 

    

 

       International Journal of Advanced Research in Science, Communication and Technology (IJARSCT) 

                               International Open-Access, Double-Blind, Peer-Reviewed, Refereed, Multidisciplinary Online Journal 

Volume 4, Issue 5, May 2024 

Copyright to IJARSCT DOI: 10.48175/IJARSCT-18425   154 

www.ijarsct.co.in  

Impact Factor: 7.53 

Additional commands are found within the five menus: File, Edit, Sketch, Tools, Help. The menus are context 

sensitive, which means only those items relevant to the work currently being carried out are available. 

 

FILE 

New 

Creates a new instance of the editor, with the bare minimum structure of a sketch already in place. 

Open 

Allows to load a sketch file browsing through the computer drives and folders. 

Open Recent 

Provides a short list of the most recent sketches, ready to be opened. 

 

Sketchbook 

Shows the current sketches within the sketchbook folder structure; clicking on any name opens the corresponding sketch 

in a new editor instance. 

Examples 

Any example provided by the Arduino Software (IDE) or library shows up in this menu item. All the examples are 

structured in a tree that allows easy access by topic or library 

Close 

Closes the instance of the Arduino Software from which it is clicked. 

Save 

Saves the sketch with the current name. If the file hasn't been named before, a name will be provided in a "Save as..." 

window. 

Save as... 

Allows to save the current sketch with a different name. 

Page Setup 

It shows the Page Setup window for printing. 

Print 

Sends the current sketch to the printer according to the settings defined in Page Setup. 

Preferences 

Opens the Preferences window where some settings of the IDE may be customized, as the language of the IDE interface. 

Quit 

Closes all IDE windows. The same sketches open when Quit was chosen will be automatically reopened the next time 

you start the IDE. 

EDIT 

Undo/Redo 

Goes back of one or more steps you did while editing; when you go back, you may go forward with Redo. 

Cut 

Removes the selected text from the editor and places it into the clipboard. 

Copy 

Duplicates the selected text in the editor and places it into the clipboard. 

Copy for Forum 

Copies the code of your sketch to the clipboard in a form suitable for posting to the forum, complete with syntax 

coloring. 

Copy as HTML 

Copies the code of your sketch to the clipboard as HTML, suitable for embedding in web pages. 

Paste 

Puts the contents of the clipboard at the cursor position, in the editor 
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• Select All 

Selects and highlights the whole content of the editor. 

• Comment/Uncomment 

Puts or removes the // comment marker at the beginning of each selected line. 

• Increase/Decrease Indent 

Adds or subtracts a space at the beginning of each selected line, moving the text one space on the right or eliminating a 

space at the beginning. 

• Find 

Opens the Find and Replace window where you can specify text to search inside the current sketch according to several 

options. 

• Find Next 

Highlights the next occurrence - if any - of the string specified as the search item in the Find window, relative to the 

cursor position. 

• Find Previous 

Highlights the previous occurrence - if any - of the string specified as the search item in the Find window relative to the 

cursor position. 

SKETCH 

• Verify/Compile 

Checks your sketch for errors compiling it; it will report memory usage for code and variables in the console area. 

• Upload 

Compiles and loads the binary file onto the configured board through the configured Port. 

• Upload Using Programmer 

This will overwrite the bootloader on the board; you will need to use Tools > Burn Bootloader to restore it and be able 

to Upload to USB serial port again. However, it allows you to use the full capacity of the Flash memory for your 

sketch. Please note that this command will NOT burn the fuses. To do so a Tools -> Burn Bootloader command must be 

executed. 

• Export Compiled Binary 

Saves a .hex file that may be kept as archive or sent to the board using other tools. 

• Show Sketch Folder 

Opens the current sketch folder. 

 • Include Library 

Adds a library to your sketch by inserting #include statements at the start of your 

code. For more details, see libraries below. Additionally, from this menu item you can access the Library Manager and 

import new libraries from .zip files. 

• Add File... 

Adds a source file to the sketch (it will be copied from its current location). The new file appears in a new tab in the 

sketch window. Files can be removed from the sketch using the tab menu accessible clicking on the small triangle icon 

below the serial monitor one on the right side of the toolbar. 

TOOLS 

• Auto Format 

This formats your code nicely: i.e. indents it so that opening and closing curly braces line up, and that the statements 

inside curly braces are indented more. 

• Archive Sketch 

Archives a copy of the current sketch in .zip format. The archive is placed in the same directory as the sketch. 

• Fix Encoding & Reload 

Fixes possible discrepancies between the editor char map encoding and other operating systems char maps. 

• Serial Monitor 

Opens the serial monitor window and initiates the exchange of data with any connected board on the currently selected 

Port. This usually resets the board, if the board supports Reset over serial port opening. 
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• Board 

Select the board that you're using. See below for descriptions of the various boards. 

• Port 

This menu contains all the serial devices (real or virtual) on your machine. It should automatically refresh every time 

you open the top-level tools menu. 

• Programmer 

For selecting a hardware programmer when programming a board or chip and not using the onboard USB-serial 

connection. Normally you won't need this, but if you're burning a bootloader to a new microcontroller, you will use this. 

• Burn Bootloader 

The items in this menu allow you to burn a boot loader onto the microcontroller on an Arduino board. This is not 

required for normal use of an Arduino or Genuino board but is useful if you purchase a new ATmega microcontroller 

(which normally come without a bootloader). Ensure that you've selected the correct board from the Boards menu 

before burning the bootloader on the target board. This command also set the right fuses. 

 HELP 

Here you find easy access to a number of documents that come with the Arduino Software (IDE). You have access to 

Getting Started, Reference, this guide to the IDE and 

other documents locally, without an internet connection. The documents are a local copy of the online ones and may 

link back to our online website. 

• Find in Reference 

This is the only interactive function of the Help menu: it directly selects the relevant page in the local copy of the 

Reference for the function or command under the cursor. 

SKETCHBOOK 

The Arduino Software (IDE) uses the concept of a sketchbook: a standard place to store your programs (or sketches). 

The sketches in your sketchbook can be opened from the File > Sketchbook menu or from the Open button on the 

toolbar. The first time you run the Arduino software, it will automatically create a directory for your sketchbook. You 

can view or change the location of the sketchbook location from with the Preferences dialog. 

Beginning with version 1.0, files are saved with a .ino file extension. Previous versions use the. pde extension. You 

may still open. pde named files in version 1.0 and later, the software will automatically rename the extension to. ino. 

Tabs, Multiple Files, and Compilation 

Allows you to manage sketches with more than one file (each of which appears in its own tab). These can be normal 

Arduino code files (no visible extension), C files (.c extension), C++ files (.cpp), or header files (.h). 

UPLOADING 

Before uploading your sketch, you need to select the correct items from the Tools > Board and Tools > Port menus. The 

boards are described below. On the Mac, the serial port is probably something like /dev/tty.usbmodem241 (for an Uno 

or Mega2560 or Leonardo) or 

/dev/tty.usbserial-1B1     (for     a     Duemilanove     or     earlier     USB     board),     or /dev/tty.USA19QW1b1P1.1 

(for a serial board connected with a Keyspan USB-to-Serial adapter). On Windows, it's probably COM1 or COM2 (for 

a serial board) or COM4, COM5, 

COM7, or higher (for a USB board) - to find out, you look for USB serial device in the ports section of the Windows 

Device Manager. On Linux, it should be /dev/ttyACMx , 

/dev/ttyUSBx or similar. Once you've selected the correct serial port and board, press the upload button in the toolbar or 

select the Upload item from the Sketch menu. Current Arduino boards will reset automatically and begin the upload. 

With older boards (pre-Diecimila) that lack auto-reset, you'll need to press the reset button on the board just before 

starting the upload. On most boards, you'll see the RX and TX LEDs blink as the sketch is uploaded. The Arduino 

Software (IDE) will display a message when the upload is complete, or show an error. 

When you upload a sketch, you're using the Arduino bootloader, a small program that has been loaded on to the 

microcontroller on your board. It allows you to upload code without using any additional hardware. The bootloader is 

active for a few seconds when the board resets; then it starts whichever sketch was most recently uploaded to the 

microcontroller. The bootloader will blink the on-board (pin 13) LED when it starts (i.e. when the board resets). 
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LIBRARIES 

Libraries provide extra functionality for use in sketches, e.g. working with hardware or manipulating data. To use a 

library in a sketch, select it from the Sketch > Import Library menu. This will insert one or more #include statements at 

the top of the sketch and compile the library with your sketch. Because libraries are uploaded to the board with your 

sketch, they increase the amount of space it takes up. If a sketch no longer needs a library, simply delete its #include 

statements from the top of your code. 

There is a list of libraries in the reference. Some libraries are included with the Arduino software. Others can be 

downloaded from a variety of sources or through the Library Manager. Starting with version 1.0.5 of the IDE, you do 

can import a library from a zip file and use it in an open sketch. See these instructions for installing a third-party library. 

  

THIRD-PARTY HARDWARE 

Support for third-party hardware can be added to the hardware directory of your sketchbook directory. Platforms 

installed there may include board definitions (which appear in the board menu), core libraries, bootloaders, and 

programmer definitions. To install, create the hardware directory, then unzip the third-party platform into its own sub-

directory. (Don't use "arduino" as the sub-directory name or you'll override the built-in Arduino platform.) To uninstall, 

simply delete its directory. 

For details on creating packages for third-party hardware, see the Arduino IDE 1.5 3rd party Hardware specification. 

  

SERIAL MONITOR 

This displays serial sent from the Arduino or Genuino board over USB or serial connector. To send data to the board, 

enter text and click on the "send" button or press enter. Choose the baud rate from the drop-down menu that matches 

the rate passed to Serial.begin in your sketch. Note that on Windows, Mac or Linux the board will reset (it will rerun 

your sketch) when you connect with the serial monitor. Please note that the 

Serial Monitor does not process control characters; if your sketch needs a complete management of the serial 

communication with control characters, you can use an external terminal program and connect it to the COM port 

assigned to your Arduino board. 

  

VII. CODE 

// HC-SR04 - Version: 1.1.2 

#include "thingProperties.h" #include <LiquidCrystal.h> #include <OneWire.h> 

#include <DallasTemperature.h> #include <HCSR04.h> 

#include <TaskScheduler.h> void t2Callback(); 

Task t2(1000, TASK_FOREVER, &t2Callback); Scheduler runner; 

#define mtr1_f 15 

#define mtr1_b 2 

#define mtr1_en 23 

#define mtr2_f 4 

#define mtr2_b 16 

#define mtr2_en 22 

// Setting PWM properties const int freq = 30000; 

const int pwmChannel = 0; const int resolution = 8; 

int dutyCycle = 150; 

HCSR04 hc(18, 19); //initialisation class HCSR04 (trig pin , echo pin) 

const int oneWireBus = 5; OneWire oneWire(oneWireBus); 

DallasTemperature sensors(&oneWire); 

const int rs = 26, en = 33, d4 = 27, d5 = 14, d6 = 25, d7 = 13; LiquidCrystal lcd(rs, en, d4, d5, d6, d7); 

const int metalpin = 21; bool stopflag = 0; 

int lastdata = 0; int datanow = 0; int dist = 0; float temp = 0.0; 

bool metal_sense = 0; 
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String motorstatus = "STOP"; void t2Callback() { 

getlevel(); 

} 

void IRAM_ATTR isr() { 

if (digitalRead(metalpin) == 1) { 

metal_sense = 1; 

metalDet = 1; 

datanow = 4; take_action(); 

} else { metal_sense = 0; 

metalDet = 0; 

} 

} 

void setup() { pinMode(mtr1_f, OUTPUT); pinMode(mtr1_b, OUTPUT); pinMode(mtr2_f, OUTPUT); 

pinMode(mtr2_b, OUTPUT); 

pinMode(mtr1_en, OUTPUT); pinMode(mtr2_en, OUTPUT); ledcSetup(pwmChannel, freq, resolution); 

ledcAttachPin(mtr1_en, pwmChannel); ledcAttachPin(mtr2_en, pwmChannel); Serial.begin(115200); 

pinMode(metalpin, INPUT); pinMode(oneWireBus, INPUT_PULLUP); digitalWrite(mtr1_f, HIGH); 

digitalWrite(mtr1_b, HIGH); 

digitalWrite(mtr2_f, HIGH); digitalWrite(mtr2_b, HIGH); lcd.begin(16, 2); 

lcd.clear(); lcd.setCursor(0, 0); 

lcd.print("IOT Based Metal"); lcd.setCursor(0, 1); lcd.print("Detector"); 

sensors.begin(); delay(1000); initProperties(); 

ArduinoCloud.begin(ArduinoIoTPreferredConnection); setDebugMessageLevel(0); ArduinoCloud.printDebugInfo(); 

runner.init(); Serial.println("Initialized scheduler"); delay(2000); 

runner.addTask(t2); Serial.println("added t2"); t2.enable(); Serial.println("Enabled t2"); 

attachInterrupt(metalpin, isr, RISING); 

} 

void loop() { 

ArduinoCloud.update(); getlevel(); 

gettemp(); lcd_display(); debugSerial(); take_action(); 

} 

/* 

Since GetButtonPress is READ_WRITE variable, onGetButtonPressChange() is executed every time a new value is 

received from IoT Cloud. 

*/ 

void onGetButtonPressChange() { 

// Add your code here to act upon GetButtonPress change Serial.println("ButtonPress :" + String(getButtonPress)); 

datanow = getButtonPress; 

take_action(); 

} 

/* 

Since SpeedSet is READ_WRITE variable, onSpeedSetChange() is executed every time a new value is received from 

IoT Cloud. 

*/ 

void onSpeedSetChange() { 

// Add your code here to act upon SpeedSet change 

Serial.println("Setspeed :" + String(speedSet)); dutyCycle = speedSet; 

ledcWrite(pwmChannel, dutyCycle); 

} 
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void debugSerial() { 

if (Serial.available()) { 

String rx = Serial.readString(); datanow = rx.toInt(); 

} 

} 

void gettemp() { sensors.requestTemperatures(); 

float temperatureC = sensors.getTempCByIndex(0); float temperatureF = sensors.getTempFByIndex(0); 

// Serial.print(temperatureC); 

// Serial.println("ºC"); 

// Serial.print(temperatureF); 

// Serial.println("ºF"); 

temp = sensors.getTempCByIndex(0); temperature = temp; 

//delay(5000); 

} 

void lcd_display() { lcd.clear(); lcd.setCursor(0, 0); lcd.print("T:"); lcd.print(temp, 0); lcd.print(" D:"); lcd.print(dist); 

lcd.print(" M:"); lcd.print(metal_sense); lcd.setCursor(0, 1); 

lcd.print("Motor:"); lcd.print(motorstatus); 

Serial.println("T: " + String(temp) + ", M:" + String(metalDet) + ", ob:" + String(dist) 

+ ", sp:" + String(speedSet) + ", dn:" + String(datanow) + ", ls:" + String(lastdata)); 

} 

void getlevel() { dist = hc.dist(); 

//rainlevel = map(rainlevel,16,4,0,100); 

 //Serial.println("Fuel-Level: " + String(dist)); if (dist <= 15) { 

Obstacle = 1; 

if (datanow != 5) { datanow = 4; 

} 

} 

Else { Obstacle = 0; 

} 

if (digitalRead(metalpin) == 1) { metal_sense = 1; 

metalDet = 1; take_action(); 

} else { metal_sense = 0; 

metalDet = 0; 

} 

} 

void output_high(int x) { digitalWrite(x, HIGH); 

} 

 void output_low(int x) { digitalWrite(x, LOW); 

} 

void take_action() { 

//Serial.println("data-now:" + String(datanow) + " lastdata:" + String(lastdata)); if (lastdata != datanow) { 

lastdata = datanow; switch (lastdata) { 

case 1: // motor Forward 

{ 

output_high(mtr1_f); output_low(mtr1_b); output_high(mtr2_f); output_low(mtr2_b); 

motorstatus = "FWR"; 

//lcd_putc("\f MOTOR: START \n FORWORD"); break; 

} 

case 2: // motor LEFT 
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{ 

output_high(mtr1_f); output_low(mtr1_b); output_low(mtr2_f); 

output_low(mtr2_b); motorstatus = "LEFT"; break; 

//delay_ms(200); 

//lcd_putc("\fMOTOR:RIGHT TRUN"); 

} 

case 4: // motor stop 

{ 

output_low(mtr1_f); output_low(mtr1_b); output_low(mtr2_f); 

output_low(mtr2_b); motorstatus = "STOP"; 

//delay_ms(200); 

//lcd_putc("\f MOTOR: LEFT TRUN "); break; 

} 

case 3: // motor right 

{ 

output_low(mtr1_f); output_low(mtr1_b); output_high(mtr2_f); output_low(mtr2_b); 

motorstatus = "RIGHT"; 

//lcd_putc("\f MOTOR: STOP"); break; 

} 

case 5: // motor backward 

{ 

output_low(mtr1_f); output_high(mtr1_b); output_low(mtr2_f); output_high(mtr2_b); motorstatus = "REV" 

//lcd_putc("\fMOTOR:BACKWOARD"); 

  

VII. APPLICATION: 

1. Military Metal detection of land mines. 

2. Detection of hidden artifacts. 

3. Lost treasures finding. 

 

VIII. ADVANTAGES 

1. Remote operation of detecting land mine. 

2. Low cost 

3. Easy Maintenances 

 

IX. CONCLUSION 

Current work presents a metal detecting robot using radio frequency communication with wireless Video transmission 

and it is depicted and put into with At ESP32 MUC in embedded system field. The robot is proceeded in finicky track 

using switches and the beeping sounds produced. Experimental work has been The exhibited carefully. The results 

shows that higher effectiveness is accomplished using the embedded system. The current work is exhibited to be highly 

beneficial for the security intention and industrial requirements. The mine sensor undertake at a constant speed without 

any issues not withstanding its extension, satisfying the specification required for the mine recognition sensor. It 

provides the enhancement of detection rate, while reforming the operability as verified by completion of all the 

detection of all detection jobs as programmed. The tests established that the robot would not pretends any performance 

issue for setting up of the mine detection sensor 
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